[Lava-users] Git error after upgrading to 2017.10-1: "fatal: index-pack failed"

Dragos Iorgulescu Dragos.Iorgulescu at enea.com
Tue Nov 7 09:08:49 UTC 2017


Thanks Neil!

I will also discuss this with our lab admin, to see what's going on with those repos.

--
/Dragoş


On 2017-11-07 10:55:32+02:00 Neil Williams wrote:

On 7 November 2017 at 08:44, Dragos Iorgulescu <Dragos.Iorgulescu at enea.com<mailto:Dragos.Iorgulescu at enea.com>> wrote:
Hi again!

I've managed to reproduce this by hand, by trying to clone the same repos as root, on the same host.
It seems that the use of "--depth=1" makes the command fail. When --depth is not used, the clone works correctly:
https://lists.linaro.org/pipermail/lava-announce/2017-September/000038.html<https://url10.mailanyone.net/v1/?m=1eBzfK-0000fs-6P&i=57e1b682&c=OrDyiE9GP7ja4RSHoWgDoQazPnF95HX-Tm0vfNUyvBQ_4OpXCNUkFfDr8c86cZn0YQF6_Xufui_j2NVSBiDAXVGEP92c7l3UJPRBL4OBd0WLXdgEPlQXACSvVxQN9cVYGjh_VC65JIlsjBReihoUR6NPLHcrXULU9Wr02eYFVs0ldSGQ3pVl2ssSuHbpGKCrHzMU3TpLEiUGyb0NWWGB-8aBWpV1wb6T7uWHrH_f6YvQmeAkunvAjxEvQ1jwEdiRvLzdrvQMxZYKw5yD1rZZdkAR06XC-98q7IM9BBbt_4I>
c6e06463 LAVA-998 - Default to shallow clones in overlay
https://projects.linaro.org/browse/LAVA-998<https://url10.mailanyone.net/v1/?m=1eBzfK-0000fs-6P&i=57e1b682&c=KNo1Uo1fuFhTHlJ2WRpkorIhxd_0AX_aUDFLvY7M-VHO7DPd46OCNMNReHXX0iBWTMC9KiQbSfkaoOSFI3Ltex-wt57RvBhAX-Lr4qCOXO74BTdXMf0MLZOao-POtKXlXXV2xeCnI0BRSiA66gpXQqUwSxWn8vTdhLTxEOA8Wd9-impgpthDsvD55EeEF-nSwncqRfVlZHvep05BOyxYxyd_G5MakAzHRbdUGj88Ho60-P8x3rcs56pMCjEPtm2Y>
That could lead you to: https://review.linaro.org/#/c/21060/5/doc/v2/test-repositories.rst<https://url10.mailanyone.net/v1/?m=1eBzfK-0000fs-6P&i=57e1b682&c=XC0z_QYOcjKFSgS3GpkLe8XCbQq9CENuQAMP3009bxNXtFUjk2I3mWamJeR3F45gfAtHk-Xe0ekW1BflMlduMTr_Vx-l2QhBMtdUkEn9ELOuDNIWOW_FkmWwZ_LvKN-9VU8jLqe5IMnvjLkXXMs6sq3ZrqKcWqofyRY6v95QgFtMd9Vvb9SgRzgmNbE36WiWsF1DlfzFf6ys2MO2CmDi8dj8MyjCVsoN5udt6oiPVMVyot10qUmX_rtiUykacAtbKLMAPdzpoApasVWJjoDfRQ>
That leads to here: https://staging.validation.linaro.org/static/docs/v2/test-repositories.html#shallow-clones-in-git<https://url10.mailanyone.net/v1/?m=1eBzfK-0000fs-6P&i=57e1b682&c=trKQbn4Rnle6I2ogWEupvIBF1D0stecBr0gRE79Swl8rMhbL0zj1UfVVrg1hcLsR_hesLlK3DJsjNZ1d7yuRtquP6_JHzUcS6Hk7EtmLTp0YQehAZdhQcNMLdWcKyicf8yEUJ12Av4Tk1NYAo4zPpv4psUpKBkql5gLoCeZ3uxUH3LBumpxXoBlSAhCHVsPpLaf45j0yg-Agn7mK3O5NJPdxiSS1-yi4z4lrU9HrtKlLgxCK5FlR4Q0vDwe8HSu0bRNPmhQjXHp3o0-KkCDId82UmiCEtVqyJ2m6NZsoqfdNTZwdhXPsXsfO9gf-QQk6>
That includes an example of how to request not to use shallow clones for specific repositories.
However, you should check why this repository cannot be used as a shallow clone - it may be that the repository itself has errors in git which need to be fixed up.

root at eltf-qemu01:~/tmp_lava# git clone git://git.enea.se/eltf/lava.git<http://git.enea.se/eltf/lava.git> /var/lib/lava/dispatcher/tmp/384/lava-overlay-SXDmxh/lava-384/0/tests/0_healthcheck-runner --depth=1
Cloning into '/var/lib/lava/dispatcher/tmp/384/lava-overlay-SXDmxh/lava-384/0/tests/0_healthcheck-runner'...
fatal: The remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed

root at eltf-qemu01:~/tmp_lava# git clone git://git.enea.se/eltf/lava.git<http://git.enea.se/eltf/lava.git> /var/lib/lava/dispatcher/tmp/384/lava-overlay-SXDmxh/lava-384/0/tests/0_healthcheck-runner
Cloning into '/var/lib/lava/dispatcher/tmp/384/lava-overlay-SXDmxh/lava-384/0/tests/0_healthcheck-runner'...
remote: Counting objects: 1253, done.
remote: Compressing objects: 100% (1241/1241), done.
remote: Total 1253 (delta 675), reused 0 (delta 0)
Receiving objects: 100% (1253/1253), 239.59 KiB | 0 bytes/s, done.
Resolving deltas: 100% (675/675), done.
Checking connectivity... done.

Is there a way to avoid the use of the --depth parameter (i.e. a setting), or should I just make the changes in the LAVA code?
Just because LAVA is open source does not mean you should modify the code every time. Please read the documentation.

Thanks again!
--
/Dragoş


On 2017-11-06 11:30:35+02:00 Dragos Iorgulescu wrote:

Hi!

Just upgraded from 2017.6 to 2017.10-1.
Tried re-running some jobs that worked fine just before the upgrade and noticed that git checkouts can no longer pe performed.

The encountered error is:
fatal: The remote end hung up unexpectedly\nfatal: early EOF\nfatal: index-pack failed\n

Tried checking out manualy on the host, using the same repo. It works.

How could I proceed investigating this?
Could this be related to some lava user configuration that got reset (I don't know if git-related configs are associated with LAVA)?

Thanks in advance (again)!
P.S: I have attached the plain job log
--
/Dragoş

_______________________________________________
Lava-users mailing list
Lava-users at lists.linaro.org<mailto:Lava-users at lists.linaro.org>
https://lists.linaro.org/mailman/listinfo/lava-users<https://url10.mailanyone.net/v1/?m=1eBzfK-0000fs-6P&i=57e1b682&c=HnXk-W_2Q9wkfySpmfMUulhQ0j69VxqAeojK6Z6DOgRxfL1bFnUR_cKKHj4TOkYAqdkNGTWZQ_j5yShaRcksg4S2XUvBOY2u_0oFriYpsF5HGyYRJRaG-pYp7lIOHoUQsV5BvWRAxHiNiAQERa6PdoozBaakKt6rkoqPKRw5CgOI8i64S435p0cqrVFA2bJFUTgF1e897PuFfK86huW9jSA2uoC26wToC4xaM_ghoZ2juJXsWENlMWHg5oFcLO5R>


--

Neil Williams
=============
neil.williams at linaro.org<mailto:neil.williams at linaro.org>
http://www.linux.codehelp.co.uk/<https://url10.mailanyone.net/v1/?m=1eBzfK-0000fs-6P&i=57e1b682&c=rmRhMGoVhrjASaUKwNrZvW72cUJY4u9dwRwOSIlfl2TOk0dR8LYrF9dDQh1GwfIZLVYcyBWAf5tdABr1kpKfdNt1TsB5zRuvWfHJNNP9GegmuWH4YwSoT2HNo1GT_aa9_pnPA3ywkXDbgF1Bc1NxS77LZBhJcK0H9RdArt2zmjKdyjMSPBwBZodiZ3D47DQKWmQSneUKs_Mrhx1LFDkTC9Y-bbfi9PYrBI33HEaS2Q4>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linaro.org/pipermail/lava-users/attachments/20171107/355c76fc/attachment-0001.html>


More information about the Lava-users mailing list