[Lava-users] Interactive test action unreliable behavior

Philippe Mazet philippe.mazet at nxp.com
Tue Dec 3 08:18:21 UTC 2019


Hi All,

I am experimenting with the interactive test action, but cannot get it to work reliably.

I tried to replicate what is documented here: https://docs.lavasoftware.org/lava/interactive.html#writing-tests-interactive
I also took as example a job mentioned previously on this mailing list: https://validation.linaro.org/scheduler/job/1925569/definition

But If I come down to the simplest uboot test job (yaml + log attached), I still see false verdicts.
I first set 2 variables in uboot. Then I print them, and verify if the output contains the expected string.
Only the first case behaves as expected: "fail-expected-1".

All following tests go wrong:
Test case "fail-expected-2" fails, but for a wrong reason: "Matched a prompt (was expecting a success): '=> '"
And remaining test cases also show a wrong verdict because of this. Including the last 2 TCs which are supposed to pass, but are marked as failed.

I also tested in Linux and on a different platform, and the behavior is the same.

Am I missing something with the syntax? Or with serial console settings?

Thanks a lot for your help,

Philippe Mazet


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lavasoftware.org/pipermail/lava-users/attachments/20191203/01d104c2/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: job_24191.zip
Type: application/x-zip-compressed
Size: 4376 bytes
Desc: job_24191.zip
URL: <http://lists.lavasoftware.org/pipermail/lava-users/attachments/20191203/01d104c2/attachment.bin>


More information about the Lava-users mailing list