When I was doing the lkft upgrade this morning I noticed that there is a Buster dependency for LAVA. One of the workers had somehow been missed out on the Buster upgrade and was still on Stretch. I discovered the following:
lava-dispatcher : Depends: python3-requests (>= 2.20.0) but 2.12.4-1 is to be installed
Does this mean we really have to check for Debian version 10.0 or later for remote, bare metal, workers?
LAVA Lab Lead
t: (+44) (0) 1223 400063